Sie sind nicht angemeldet.

1

Samstag, 28. Dezember 2013, 17:09

ManiAdminPlugin - keine Rechte

Hallo,

entschuldigt bitte, dass ich im falschem Forum schreibe. Ich habe das richtige Forum schon gefunden, nur kann ich dort nicht schreiben. Sobald ich es betrete bin ich ausgeloggt und hab keine Rechte ein Thema zu verfassen. Ihr dürft das gerne verschieben, vorausgesetzt ich kann dann dort antworten :-D

Zur Sache:

Ich habe auf meinem altem Server einen CS:S-Server aufgesetzt. Funktioniert auch wunderbar, obwohl ein bisschen nervig, seit man das über SteamCMD machen muss. Aber gut. Nun wollte ich mir dafür Mani-Admin-Plugin einrichten. Das ist ja auch das einfachste auf der Welt, eigentlich. Dachte ich auch immer. :-D

Das Plugin wird erkannt aber ich bekomme keine Adminrechte. Es ist scheiß egal, was ich probiere, es funktioniert nicht, ich erhalte immer nur die Meldung, dass ich nicht berechtigt bin das adminmenu aufzurufen.

Ich hab dafür mehrere clients.txt erstellt und getestet, keine funktioniert. Auch über die Console kann ich mir keine Adminrechte geben.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
"clients.txt" {
  "version"   "1"
  
  // Grupppe fuer alle Spieler
  "players" {
	// Eindeutiger Client-Name
	"Admin1" {
  	// Echter Client-Name
  	"name"  "Christian"
  	// Steam-ID des Clients
  	"steam" "Meine-ID"
  	"groups" {
    	"Admin" "Serveradmin"
    	"Immunity"  "Serveradmin"
  	}
	}
  }
  
  // Globale Gruppen-Rechte
  "groups" {
	"Immunity" {
  	"Serveradmin" "a b c d e f g h i j k l m n o p q r s t u v x y afk ping autojoin grav Immunity"
  	"Clanmember"  "a b c h k n afk autojoin Immunity"
	}
	"Admin" {
  	"Serveradmin" "A B C T U V W X Y Z a b c d o p q q2 q3 r z admin client pban spray"
  	"Clanmember"  "B D E F a b c o q q2 q3 s t v w x y admin pban spray"
	}
  }
}


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
"clients.txt" {
  "version"   "1"
  
  // Grupppe fuer alle Spieler
  "players" {
	// Eindeutiger Client-Name
	"Admin1" {
  	// Steam-ID des Clients
  	"steam" "Meine-ID"
  	"groups" {
    	"Admin" "Serveradmin"
    	"Immunity"  "Serveradmin"
  	}
	}
  }
  
  // Globale Gruppen-Rechte
  "groups" {
	"Immunity" {
  	"Serveradmin" "a b c d e f g h i j k l m n o p q r s t u v x y afk ping autojoin grav Immunity"
  	"Clanmember"  "a b c h k n afk autojoin Immunity"
	}
	"Admin" {
  	"Serveradmin" "A B C T U V W X Y Z a b c d o p q q2 q3 r z admin client pban spray"
  	"Clanmember"  "B D E F a b c o q q2 q3 s t v w x y admin pban spray"
	}
  }
}


Quellcode

1
"steam" "Meine-ID"


Die ID ist korrekt. Copy und Paste beherrsche ich schon noch.

Ich hab Suchmaschinen seit gestern Abend gequält, nichts hat mir weitergeholfen, ich hab alles ausprobiert.
Das nächste Problem ist natürlich: Man findet fast nur Hilfe-Themen, Anleitungen, ... die schon einige Jahre alt sind. Überall wird noch von "adminlist.txt" gequatscht, die ja gar nicht mehr gebraucht wird. Kann also sein, dass ich nur aufgrund alter Informationen nicht weiterkomme. Aber auch die offizielle Seite hat mir nicht weitergeholfen.

Wäre also schön, wenn hier jemand eine Idee hätte. Von mir aus kann er sich das ganze auch gerne live angucken.

Gruß,

Christian

Newbie'

Profi

Beiträge: 580

Wohnort: Zuhause

Rootserver vorhanden: Nein

  • Nachricht senden

2

Samstag, 28. Dezember 2013, 17:30

Mani-Admin wird seit längerem schon NICHT mehr supportet, neue Version werden dafür wohl auch nie mehr erscheinen. Ich würde dir von abraten ganz klar. Versuch dich an Sourcemod ist um einiges schwieriger stimmt schon jedoch läuft dort alles.

Kann auch gut sein das Mani-Admin schon so kaputt ist das du keine Admins mehr eintragen kannst :D

MfG,
Newbie'

3

Samstag, 28. Dezember 2013, 17:37

https://code.google.com/p/mani-admin-plugin/downloads/list
Letzten Monat gab es ein Update versuch das doch mal

Jackmaster

Super Moderator

Beiträge: 660

Rootserver vorhanden: Ja

  • Nachricht senden

4

Samstag, 28. Dezember 2013, 17:38

Die neueste Gametypes: https://mani-admin-plugin.googlecode.com…es_21.11.13.zip

Edit: Hat sich erledigt, siehe Bara ^^

5

Samstag, 28. Dezember 2013, 18:09

Danke meine Freunde, ich werde das sofort ausprobieren und melde mich dann wieder hier. :)

EDIT:
Problem ist damit nicht gelöst. Es bleibt dabei. Admin in die Console eintippen ergibt nur: "You are not authorised to run the command admin"

Das Problem sind wirklich nur die Adminrechte. Die normalen Spielerrechte wie @ text oder ff, etc. pp funktionieren Reibungslos. Ich bekomme nur keine Adminrechte...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »fluxX« (28. Dezember 2013, 18:43)


Newbie'

Profi

Beiträge: 580

Wohnort: Zuhause

Rootserver vorhanden: Nein

  • Nachricht senden

6

Samstag, 28. Dezember 2013, 22:11

Wie schon erwähnt du solltest auf Sourcemod umsteigen, viel Support kannst du auch nicht erwarten da niemand hier Mani nutzt. Mani gehört in die Tonne.

MfG,
Newbie'

Jackmaster

Super Moderator

Beiträge: 660

Rootserver vorhanden: Ja

  • Nachricht senden

7

Samstag, 28. Dezember 2013, 22:21

Probier mal folgende clients.txt

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
"clients.txt"
{
	"version"	"1"

	// This key group lists all your client players
	"players"
	{
		// This must be a unique client name
		"Client_1"
		{
			// Client real name
			"name"	"Client_1"
			// Steam ID for client
			"steam"	"STEAM_0:1:1234"
			// These are personal access flags for a player
			"flags"
			{
				"Admin"	"grav pban A B C D E F G H I J K L M N O P Q R S T U V W X Y"
				"Admin"	"Z a b c d e f g i j k l m o p q r s t v w x y z client admin"
				"Admin"	"spray"
			}
		}
	}
}


Bei steam einfach deine STEAMID eintragen.


gruß

8

Sonntag, 29. Dezember 2013, 01:09

Herzlichen Dank Jackmaster. Die funktionierte auf anhieb.

Aber warum funktioniert meine nicht? Ich seh da eigentlich keinen Fehler...

Jackmaster

Super Moderator

Beiträge: 660

Rootserver vorhanden: Ja

  • Nachricht senden

9

Sonntag, 29. Dezember 2013, 12:37

Keine Ahnung ^^ Ich hab dir einfach meine gegeben die ich früher benutzt hatte.
Vielleicht ein Klammer Fehler irgendwo..
Aber prima das es geklappt hat :)

10

Dienstag, 31. Dezember 2013, 04:04

Zitat

Vielleicht ein Klammer Fehler irgendwo..
Eigentlich nicht, habs mehrfach kontrolliert. Aber is ja nun auch egal, es funktioniert nun, dass is die Hauptsache. :D
Danke nochmal.

Zitat

Wie schon erwähnt du solltest auf Sourcemod umsteigen
Naja, ich bin MAP noch von früher gewohnt von nem Server wo ich gespielt habe. Und ich muss zugeben, was die ganzen Mods & Plugins etc. pp angeht hab ich noch nicht so den Überblick. Weil ich mich mit CS-Servern nie wirklich auseinandergesetzt habe, ist mein erster eigener CS-Server.
Hätte nicht gedacht, dass es dafür so viele Sachen gibt, ist ja fast schlimmer als die FreeBSD-Port-Sammlung :-D

Naja um auf den Punkt zu kommen: Ich kenne Sourcemod nicht. Ich habs mir mal angeguckt bzw. die Beschreibung und Befehle dazu.
Und finde ich es ziemlich kompliziert gestaltet, wenn man den Befehlsumfang mit dem Nutzen vergleicht.

Beiträge: 2 495

Wohnort: Schwelm

Beruf: Immobilien-Verwalter / Serveradministrator

Rootserver vorhanden: Nein

  • Nachricht senden

11

Donnerstag, 2. Januar 2014, 21:15

Über kurz oder lang wirst du dich aber mit SM auseinandersetzen MÜSSEN...

Erspar dir und deinen Servern diverese Fehler und probier es einfach mal.


12

Freitag, 3. Januar 2014, 03:17

Zitat

Erspar dir und deinen Servern diverese Fehler und probier es einfach mal.
Ich habs vorhin mal versucht. Funktioniert aber nicht. Das Ding wird scheinbar gar nicht erkannt, denn irgendwie existiert kein einziger Befehl.
Und so wie ich das rausgelesen habe, muss man im Grunde nur die richtige Version runterladen und hochladen - naja und die Admins eintragen. Was ja nun nicht so schwer ist.

Also scheinbar kann ich innerhalb von wenigen Stunden einen kompletten Server aufsetzen, mit allem was man so braucht. Aber für nen Counterstrikeserver schein ich zu dumm zu sein :rolleyes:

Newbie'

Profi

Beiträge: 580

Wohnort: Zuhause

Rootserver vorhanden: Nein

  • Nachricht senden

13

Freitag, 3. Januar 2014, 07:34

Um Sourcemod zum laufen zu bringen musst du Metamod installieren dieses läd dann Sourcemod ohne Metamod kein Sourcemod.

14

Freitag, 3. Januar 2014, 16:41

Ja, soweit war ich auch. Und Metamod scheint auch geladen zu werden:

Zitat

meta version
Metamod:Source version 1.10.0
Build ID: 860:a58a1912f602
Loaded As: Valve Server Plugin
Compiled on: Aug 25 2013
Plugin interface version: 15:14
SourceHook version: 5:5
http://www.metamodsource.net/

Und Sourcemod funktioniert irgendwie, aber irgendwie auch nicht. Geb ich z.B "find sm_" ein, so werden mir alle möglichen Befehle angezeigt. Versuch ich diese Befehle aber zu benutzen erhalte ich nur die Meldung "command sm_admin not found" (oder was auch immer ich da eingebe eben).
Als Admin hab ich mich eingetragen auch mit Flag z, an mangelnden Rechten sollte es also eigentlich nicht liegen.

Edit: Nun funktionierts. Problem war: In der Anleitung steht man müsse in die metamod.ini eintragen
addons\sourcemod\bin\sourcemod_mm
Richtig ist aber gewesen: addons\sourcemod\bin\sourcemod_mm_i486

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Christian« (3. Januar 2014, 17:16)


Newbie'

Profi

Beiträge: 580

Wohnort: Zuhause

Rootserver vorhanden: Nein

  • Nachricht senden

15

Freitag, 3. Januar 2014, 19:02

Edit: Nun funktionierts. Problem war: In der Anleitung steht man müsse in die metamod.ini eintragen
addons\sourcemod\bin\sourcemod_mm
Richtig ist aber gewesen: addons\sourcemod\bin\sourcemod_mm_i486
Du musst da nichts eintragen, das war damals nur so. Das Tut war wohl etwas alt.

16

Freitag, 3. Januar 2014, 20:13

Zitat

Du musst da nichts eintragen, das war damals nur so. Das Tut war wohl etwas alt.
Mit diesem Eintrag funktioniert es nun aber. Komplett ohne Eintrag und mit dem falschem Eintrag funktionierte es nicht.
Hab es eben nochmal getetest und den Eintrag entfernt: Danach funktionierte wieder nichts.

Aber wie dem auch sei: Ich nehme an MAP brauch ich nicht mehr? Wenn ich das richtig überblicke, kann ich das selbe auch alles mit Sourcemod bewerkstelligen?

Newbie'

Profi

Beiträge: 580

Wohnort: Zuhause

Rootserver vorhanden: Nein

  • Nachricht senden

17

Freitag, 3. Januar 2014, 20:20

Dann fehlt dir unter addons/metamod aber die sourcemod.vdf

Diese sieht wie folgt aus:

Quellcode

1
2
3
4
5
"Metamod Plugin"
{
	"alias"		"sourcemod"
	"file"		"addons/sourcemod/bin/sourcemod_mm"
}


Somit wird es normal geladen.

Ja würde Mani auf jedenfall löschen.

18

Samstag, 4. Januar 2014, 00:43

Zitat

Dann fehlt dir unter addons/metamod aber die sourcemod.vdf
Die ist vorhanden, sogar mit genau dem Inhalt.
Aber ist ja nun auch egal, es funktioniert alles. Ich nehme nicht an, dass es zu Fehlern kommt, weil ich den Eintrag in die Metamod.ini zugefügt habe.

Zitat

Ja würde Mani auf jedenfall löschen.
Bereits geschehen, danke für eure Hilfe. :)

Ähnliche Themen