You are not logged in.

Steiftier

Beginner

  • "Steiftier" started this thread

Posts: 2

wcf.user.option.userOption53: Nein

  • Send private message

1

Tuesday, March 14th 2017, 12:51am

Hilfe bei Mod Installieren.

Nabend,

es geht um folgendes:

https://forums.alliedmods.net/showthread.php?t=275881

Furienmod für CS:GO.. hab ich früher gerne gespielt. =)

Jetzt versuche ich das Ganze auf meinen Server zu installieren.


Also der CS Server läuft. Metamod sowie Sourcemod an sich läuft wunderbar.
Phpmyadmin sowie Mysql ist vorhanden. Eine Datenbank habe ich auch schon erstellt. Aber ich weiss noch nicht genau ob das richtig ist bzw. genügt was ich gemacht hab.
Muss man da auch noch Tables erstellen?

Mein eigentliches Problem besteht darin, dass ich noch nicht einmal die dazugehörigen .sp files in .smx files compilen kann.
Ständig bekomme ich Errors dabei. Ich habe es auf dem Linuxserver versucht hab mir Sourcemod für Windows geladen und da nochmal versucht. Un habe es auf dem Online-Compiler auch versucht.

Also so wie ich es aus dem Posts im dazugehörigen Thread lesen kann scheint es bei manchen Servern schonmal zu laufen.

Habt ihr evtl. Ideen für mich wie ich diesen Mod zum Laufen bekomme?

LG Steiftier

DeaD_EyE

Administrator

Posts: 3,978

Location: Hagen

Occupation: Mechatroniker (didaktische Systeme)

wcf.user.option.userOption53: Nein

  • Send private message

2

Tuesday, March 14th 2017, 11:21am

Funktioniert, wenn man die emitsoundany.inc nach scripting/include kopiert.

Spoiler Spoiler

Source code

1
2
3
4
5
6
7
8
9
andre@andre-GP70-2PE ~/Downloads/sourcemod-1.8.0-git5975-linux/addons/sourcemod/scripting $ ./spcomp furien.sp 
SourcePawn Compiler 1.8.0.5975
Copyright (c) 1997-2006 ITB CompuPhase
Copyright (c) 2004-2015 AlliedModders LLC

Code size:            91312 bytes
Data size:            32728 bytes
Stack/heap size:      16384 bytes
Total requirements:  140424 bytes

Steiftier

Beginner

  • "Steiftier" started this thread

Posts: 2

wcf.user.option.userOption53: Nein

  • Send private message

3

Friday, March 17th 2017, 10:25pm

Danke, das hat mir weitergeholfen.

Das compilen hat dann wunderbar funktioniert.

Ich musste dann noch für die Mysql Datenbank Tables anlegen dann lief alles einwandfrei.

Lg Steiftier