You are not logged in.

Dear visitor, welcome to sourceserver.info. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

1

Friday, May 25th 2012, 4:28pm

Sourcebans Komisches Problem!

Hallo ich habe ein Komisches Problem mit Sourcebans.
Sourcebans kann auf fünf Server nicht connecten, obwohl alle einstellungen mit den anderen servern identisch ist.
Also in der /css/cstrike/addons/sourcemod/configs/databases.cfg steht alles richtig drin.

databases.cfg

PHP Source code

1
2
3
4
5
6
7
8
9
10
       "sourcebans"
    {
        "driver"            "mysql"
        "host"                "localhost"
        "database"            "sourcebans"
        "user"                "sourcebans"
        "pass"                "***************"
        //"timeout"            "0"
        //"port"            "3306"
    }


Hier ma nen Screen.



Ich hoffe es kennt jemand eine Lösung zum Problem und kann mir Helfen.

MFG
PitBuLL

Posts: 2,498

Location: Schwelm

Occupation: Immobilien-Verwalter / Serveradministrator

wcf.user.option.userOption53: Nein

  • Send private message

2

Friday, May 25th 2012, 5:18pm

Der Port ist bei dir auskommentiert...

Ausserdem wäre dann auch die sourcebans.cfg interessant.

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

3

Friday, May 25th 2012, 5:26pm

Der Port ist bei allen Servern auskommentiert und es besteht ja bei vier servern ne Verbindung.

Hier die sourcebans.cfg

Spoiler Spoiler

PHP Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
/**
* sourcebans.cfg
*
* This file contains settings for the SourceBans Source Server Plugin
* @author SteamFriends Development Team
* @version 0.0.0.$Rev: 74 $
* @copyright SteamFriends (www.steamfriends.com)
* @package SourceBans
*/

"SourceBans"
{
    "Config"
    {
        // Website address to tell where the player to go for unban, etc
        "Website"            "http://unitedclubfighters.de/sourcebans"

        // Allow or disallow admins access to addban command
        "Addban"            "1"

        // Allow or disallow admins access to unban command
        "Unban"                "1"
        
        // The Tableprefix you set while installing the webpanel. (default: "sb")
        "DatabasePrefix"    "sb"

        // How many seconds to wait before retrying when a players ban fails to be checked. Min = 15.0 Max = 60.0
        "RetryTime"            "45.0"
        
        // How often should we process the failed ban queue in minutes
        "ProcessQueueTime"    "5"

        // Should the plugin automaticaly add the server to sourcebans 
        // (servers without -ip being set on startup need this set to 0)
        "AutoAddServer"        "0"

        // Enable backing up config files after getting admins from database (1 = enabled, 0 = disabled)
        "BackupConfigs"    "1"

        // Enable admin part of the plugin (1 = enabled, 0 = disabled)
        "EnableAdmins"    "1"
        
        // Require the admin to login once into website
        "RequireSiteLogin"    "0"

        // This is the ID of this server (Check in the admin panel -> servers to find the ID of this server)
        "ServerID"        "1"
    }

    /*
     * Generic menu options for if a reason isn't supplied in a ban
     * Without a supplied reason the ban will never be written to the database
     */
    "BanReasons"
    {
        "Hacking"    "Hacking"
        "Exploit"    "General Exploit of Game/Map/Server"
        "TK"    "Team Killing"
        "TF"    "Team Flashing"
        "CommSpam"    "Spamming Mic/Chat"
        "BadSpray"    "Inappropriate Spray"
        "BadLang"    "Inappropriate Language"
        "BadName"    "Inappropriate Name"
        "IgnoreAdmin"    "Ignoring Admins"
        "Stacking"    "Team Stacking"
        "Own Reason"    "Own Reason"
    }
    
    /*
     * Submenu options for when "Hacking" is selected
     * If "Hacking" is removed from the menu above this will not be accessable
     */
    "HackingReasons"
    {
        "Aimbot"    "Aimbot"
        "Antirecoil"    "Anti Recoil"
        "Wallhack"    "Wallhack"
        "Spinhack"    "Spinhack"
        "Speedhack"    "Speedhack"
        "Multi-Hack"    "Multi-Hack"
        "No Smoke"    "No Smoke"
        "No Flash"    "No Flash"
    }
}


Ach ja und die Server ID's stimmen auch.

rain

Super Moderator

Posts: 1,410

Location: Lutherstadt Wittenberg

Occupation: Anlagenmechaniker

wcf.user.option.userOption53: Ja

  • Send private message

4

Friday, May 25th 2012, 5:28pm

hast du sowas wie rcon_lock als script auf dem Server? Oder was auch sein kann das die IP des Servers wo das webinterface installiert ist in der banned_ip.cfg steht





PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

5

Friday, May 25th 2012, 5:36pm

Bei server eins stand die IP drin und er wird angezeigt.
Bei den anderen steht nichts drin und sie werden nicht angezeigt.
Und rcon_lock habe ich nicht.



//EDIT\\
Was auch komisch ist nach einem Server restart werden sie angezeigt aber nach ner Zeit kommt wieder der fehler.

DeaD_EyE

Administrator

Posts: 3,980

Location: Hagen

Occupation: Mechatroniker (didaktische Systeme)

wcf.user.option.userOption53: Nein

  • Send private message

6

Friday, May 25th 2012, 7:19pm

Es hat nichts mit der sourcebans.cfg zu tun. Der Query des Servers wird durch das Webinterface ausgeführt. Soweit ich weiß blockieren die Server bei zu vielen Anfragen den Query blockieren. Das Problem gab es schon öfters.

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

7

Friday, May 25th 2012, 8:33pm

Wie kann man das beheben?

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

8

Sunday, May 27th 2012, 10:43am

Hat niemand ne Idee wie man das beheben kann.

Rantanplan

Intermediate

Posts: 378

Occupation: Management

wcf.user.option.userOption53: Ja

  • Send private message

9

Sunday, May 27th 2012, 11:33am

Wo liegt denn die Datenbank? Ist das wirklich auf dem gleichen Rechner wie die Gameserver, also Localhost? Meiner Meinung nach nicht zu empfehlen, besorg dir Webspace mit externem Datenbankzugriff, bei interesse nenne ich dir gerne meinen Anbieter wo ich auch HlstatsX mit der DB hoste.

GeNeRaLbEaM

Professional

Posts: 1,537

Location: Krefeld

Occupation: Student

wcf.user.option.userOption53: Nein

  • Send private message

10

Sunday, May 27th 2012, 12:19pm

Stimmen die Server IDS der Server in der cfg mit denen im WI überein ? Das vergisst man schonmal gerne wenn man mehrere Server aufsetzt.
LG
GeNeRaLbEaM

Wer Rechtschreibfehler findet, darf sie behalten.

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

11

Sunday, May 27th 2012, 8:43pm

Ja webspace und game server liegen auf dem selben und ja alle ID's stimmen.

Und warum soll das nicht gut sein das sie auf dem selben space liegen es hat doch alles wunderbar geklappt aber auf einmal kommt der connect fehler.

Rantanplan

Intermediate

Posts: 378

Occupation: Management

wcf.user.option.userOption53: Ja

  • Send private message

12

Monday, May 28th 2012, 9:50am

Weil von Webserver und Gameserver auf einem System immer abgeraten wird, da es hier zu Laggs kommen kann. Beides sollte immer getrennt laufen. Meiner Meinung nach stimmt mit deiner MySql Config etwas nicht, hast du die Möglichkeit das mal über eine andere DB laufen zu lassen, die nicht auf localhost liegt?

Hast du den Webserver selbst installiert? Oder macht das jemand für dich?

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

13

Monday, May 28th 2012, 1:07pm

Hab ich selber gemacht ist aber komisch das es nicht mehr geht, es hat keiner was geändert.
Und leider habe ich keine andere Datenbank die nicht auf dem Root liegt.

Peace-Maker

Beginner

Posts: 45

wcf.user.option.userOption53: Nein

  • Send private message

14

Tuesday, May 29th 2012, 4:21pm

Die Webpanel -> Gameserver Verbindung hat rein gar nichts mit der Gameserver -> Datenbank Verbindung zu tun. Wenn die Spielerliste eines Servers im Webpanel nicht angezeigt werden kann, liegt das meistens daran, dass der Gameserverport beim Webserver geblockt ist oder der Gameserver die IP des Webservers gebannt hat.

Die Einstellungen der databases.cfg oder sourcebans.cfg oder sonst eine Gameservereinstellung ist komplett egal.

Laufen die fehlerhaften Server an unterschiedlichen Ports als die, die funktionieren? Mal mit

Source code

1
rcon listip
geschaut, ob die Server den Webserver irgendwann bannen? RCON Passwort in allen Scripts richtig?

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

15

Thursday, May 31st 2012, 9:31pm

Ja alle ports sind unterschiedlich.

So die server die nicht gehen sind laut banned_ip.cfg gebannt und ich habe keine ahnung warum.

Kann man das verhindern oder besser gefragt warum wird die IP gebannt?

LeXx

Unregistered

16

Thursday, May 31st 2012, 9:45pm

Hast du vielleicht die Rcon Passwörter falsch eingetragen? Weil dann steht da auch ERROR CONNECTION. Vielleicht macht die Bannliste ein Rcon Flood auf den Server so das der die Server immer wieder die Bannliste bannt.

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

17

Thursday, May 31st 2012, 9:53pm

Ich habe alle Server schon neu eingetragen mit den rcon pw's aber er bannt immer noch genau fünf Server ist schon komisch.

LeXx

Unregistered

18

Thursday, May 31st 2012, 9:55pm

hast du die Server.cfgs mal überprüft ob du da was eingestellt hast das er bei Rcon Flood bannt?

PitBuLL78

Beginner

  • "PitBuLL78" started this thread

Posts: 14

Location: Hamm

Occupation: Möbler

wcf.user.option.userOption53: Ja

  • Send private message

19

Thursday, May 31st 2012, 10:01pm

Woran erkenne ich das denn ich hab da nichts von rcon flood oder änliches drin stehen.

LeXx

Unregistered

20

Thursday, May 31st 2012, 10:33pm

Ja das ist kla das da nichts drin steht aber es gibt bestimmte Rcon Sicherheistsbefehle die wenn man 3 mal das Rcon PW eigegeben hat dann wir die IP Perma gebannt.

Similar threads